0

I am running rippled (standard configuration, I only changed node_db to Sqlite) and communicating with it through JSON RPC. On a few calls I get a response:

'error_message': 'Network not available.', 'error_code': 12, 'error': 'noNetwork'

The example commands that are doing this are:

account_info{"account":"rhPT87PasaG27VqKjEsp5j2AWNSHUWJd9Y"}
wallet_accounts{"regular_seed":"seed"}

What is causing this error to appear and how can I fix it?

  • What is the output of rippled server_info? And how long has your server been running? – David Schwartz Oct 25 '13 at 22:39
  • @DavidSchwartz I think I synchronized it fully, and when I need it I run it when testing. The server_info: {"info":{"build_version":"0.17.0-rc2","closed_ledger":{"age":2,"base_fee_xrp":1E-05,"hash":"66AC8BEAB996256DB740781EBFE82E6FF3DBAE464CFA62B0F24171222C0020FD","reserve_base_xrp":200,"reserve_inc_xrp":50,"seq":5},"complete_ledgers":"empty","hostid":"DARKWARE","last_close":{"converge_time_s":2.028,"proposers":0},"load":{"job_types":[{"avg_time":380,"in_progress":2,"job_type":"ledgerData","peak_time":1466,"per_second":2,"waiting":2}, – ThePiachu Oct 25 '13 at 23:41
  • {"avg_time":5,"job_type":"heartbeat","peak_time":10},{"job_type":"peerCommand","peak_time":13,"per_second":18}],"threads":6},"load_factor":1,"peers":23,"pubkey_node":"n9JjPFq5ibdb9nAs6Y3yFecH2Eq4xD1PdA88LCD2HFoVPHheYvXP","pubkey_validator":"none","published_ledger":"none","server_state":"connected","validation_quorum":1},"status":"success"} – ThePiachu Oct 25 '13 at 23:41
  • You have 23 peers. So that looks good. Seeing "complete_ledgers" as "empty" means it hasn't fully accepted any ledgers yet. Make sure your validators and network_quorum are configured the way you want them. (You can use my answer for reference.) – David Schwartz Oct 25 '13 at 23:43
1

This error indicates that your server is not synchronized to the Ripple network and thus doesn't have current information. It's perfectly normal when your server first starts up -- it can take ten or fifteen minutes to sync up, depending on your bandwidth and hardware.

You should make sure you're actually connected to a few servers and have your validators correctly configured. The server_info RPC command can help.

The following config entries should help:

[ips]
23.23.201.55 51235
184.73.226.101 51235
54.225.112.220 51235
54.225.123.13 51235

[validators]
n9KPnVLn7ewVzHvn218DcEYsnWLzKerTDwhpofhk4Ym1RUq4TeGw
n9LFzWuhKNvXStHAuemfRKFVECLApowncMAM5chSCL9R5ECHGN4V
n94rSdgTyBNGvYg8pZXGuNt59Y5bGAZGxbxyvjDaqD9ceRAgD85P
n9LeQeDcLDMZKjx1TZtrXoLBLo5q1bR1sUQrWG7tEADFU6R27UBp
n9KF6RpvktjNs2MDBkmxpJbup4BKrKeMKDXPhaXkq7cKTwLmWkFr

[validation_quorum]
3

You can resolve r.ripple.com for a list of server IP addresses recommended by Ripple Labs. Currently the list is 54.225.123.13, 54.227.239.106, 107.21.251.218, 184.73.226.101, 23.23.201.55, and 54.225.112.220.

  • It looks like I am lacking the validators and validation_quorum. Looking at rippled-example.cfg it also lacks those entries. – ThePiachu Oct 25 '13 at 23:53
  • 1
    You can also configure the validators with a validators.txt file. The list of validators and the quorum are the current recommended settings if you are not yourself a validator. – David Schwartz Oct 26 '13 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.