1

I have an Ubuntu 14.04 512Mb RAM/100Gb HDD server which I use to host a remote bitcoin node. bitcoind currently catches up and for some reason it just stops working after 10-20 minutes or so every time I re-launch it. Nothing interesting in debug.log:

2015-01-11 04:28:47 UpdateTip: new best=000000000000000027ce5c42b2e4b3e5cc51f441aaf3644a4fe8bf0215abae7c  height=306691  log2_work=79.261277  tx=41024325  date=2014-06-19 19:10:49 progress=0.488913
2015-01-11 04:28:47 ProcessBlock: ACCEPTED
2015-01-11 04:28:47 ProcessBlock: ORPHAN BLOCK 290, prev=00000000000000003de1051078cb951cadb90aad2e1a94019df07d431384934e
// nothing here, bitcoind not working anymore

What's going on and how can I fix it?

UPD here's the bitcoin-cli getinfo output:

{
    "version" : 90300,
    "protocolversion" : 70002,
    "blocks" : 306754,
    "timeoffset" : 0,
    "connections" : 10,
    "proxy" : "",
    "difficulty" : 13462580114.52533913,
    "testnet" : false,
    "paytxfee" : 0.00000000,
    "relayfee" : 0.00001000,
    "errors" : ""
}
3

I had a similar problem - it turned out that Bitcoin was running out of memory. (This happened when I was using one of DigitalOcean's 512MB VPS's.)

Here's what you can do to check if this is the problem:

  1. Run the command watch free -m

    You'll see something like this:

                 total       used       free     shared    buffers     cached  
    Mem:           997        891        106          0        117        640
    -/+ buffers/cache:        133        864
    Swap:         4095          0       4095
    
  2. Look at the intersection of -/+ buffers/cache and free. This is how much free memory you have. In this example, it's 864 MB.

  3. If that number drops below 10 MB before the crash, that's probably the issue.

Here's what you can do if this is the problem you're having:

  • Get a larger VPS from your provider.

  • Enable swap

  • Try adding

    dbcache=50
    maxconnections=4
    rpcthreads=2
    

    to your bitcoin.conf file.

  • It seems to be the issue indeed. For some reasons I currently can't enlarge a swap file (which is only 512MB) but bitcoind -disablewallet -dbcache=50 -maxorphanblocks=100 -maxconnections=4 -rpcthreads=2 did help so far. – Anton Jan 11 '15 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.