0

I can't get bitcoin core wallet to accept my wallet passphrase so I can get my private key out. The password is correct, as I have tried it to send out and it accepts it, but when I try on the debug it will not. Is it because of the way i write it in e.g. walletpassphase(........)600 or is it <...........>600 or is it some other way? Please help. It has come up with -32601 and parsing JSON and syntax.

1

You should write exactly

walletpassphrase "yourPassword" howmanysecondswillthewalletstayunlocked

For example

walletpassphrase "password33482" 6000

Then your wallet will stay unlocked for 6000 seconds.

(You can drop the quotes if your password doesn't have spaces, but it's always a great habit to use quotes.)

  • i have tried that quiet a few times but i just get a error – Mark Nov 13 '17 at 7:16
  • @Mark what error do you get? – MeshCollider Nov 13 '17 at 8:01
  • it has accepted my walletpassphase now i cant get passed the next part i click dumpprivkey then it wants me to put in my address Which address do i put in ? – Mark Nov 14 '17 at 1:23
  • @Mark It asks "Private key of which address do you want to dump?" dumpprivkey 1ABC... for example. If you want to dump all of them, dumpwallet – MCCCS Nov 14 '17 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.