5

I found an usb stick with a wallet.dat.

There is also an old notebook with Bitcoin Wallet v.8.6-beta on it. Unfortunately I can't sync it on my old notebook and therefore I am not able to send BTC to another wallet.

I then installed Bitcoin Core on my new PC and put the old wallet.dat in the directory. The bitcoin showed up in the Bitcoin Core Wallet on my new PC; BUT when I tried to send them it says "passphrase is incorrect".

I then doublechecked my passphrase using "change passphrase"-feature on the Bitcoin Wallet on the old notebook and it worked, meaning the passphrase must be correct! I could even do a transaction and put the passphrase (BUT as you know, because it is not synced - the network will not accept the transaction...)

In other forums they recommended using Electrum instead to import wallet.dat. This did not work for me.... I am not expirenced with bitcoin and IT in general....

So, do you guys have an idea what causes the incorrect passphrase in Bitcoin Core? Or could you recommend a trustworthy company to solve the problem?

  • Why would the network not accept the transaction if the wallet is not synced? It should be able to send if you can see the coins in your wallet – MeshCollider Dec 21 '17 at 23:37
1

The problem described seems quite strange. I don't know what's preventing you from unlocking the wallet.dat. I think this might be caused by InputMethod/halfwidth and fullwidth forms/CapsLock/NumLock... Double check these things before typing your passphrase.

At last, if you still cannot figure out what's preventing you from unlocking the wallet, you could try to export your private keys on your old PC, one by one.

On your new PC, if you have finished the initial syncing with latest version of Bitcoin Core, you may open the debug window, switch to the console tab, then try the rescanblockchain command. This should make your wallet balance up-to-date, which would take some time to complete.

Then, listunspent command would indicate which addresses your bitcoins are currently stored in. You may save the text, then copy it to the old PC.

On your old PC, launch bitcoin-qt. It doesn't matter whether the blockchain syncing is complete or not. Open the console, first use walletpassphrase 'YOUR_PASSPHRASE_HERE' 3600 to keep your wallet unlocked for one hour, then use dumpprivkey ONE_OF_YOUR_BITCOIN_ADDRESSES_HERE for each of your Bitcoin addresses.

Once you get all the private keys, you will be able to import them to almost any Bitcoin wallet.

0

When you are entering your passphrase in a command line you are writing your password between double quotes like this : "P@ssw0rd". You should enter your password between single quotes like this : 'P@ssw0rd'. If not, it will execute code between those double quotes which alters the password you entered.

  • Thank you fo helping me. I enter the passphrase in a pop-up window of the application (popup window which opens after I clicked send the BTC) and therefore not i a command line. Do you think this could still be related to somehow? – luki777 Dec 22 '17 at 7:05
0

It could be how different Wallet clients allows text-formatting in the Passphrase text pop-up window.

Earlier I copied the passphrase from a spreadsheet I had made. Just because the cells in the spreadsheet had properties like text-color, background color, etc. the only way my passphrase worked was by typing it in the wallet-client manually.

This isn't a full answer to your problem, but I hope this helps in some way.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.