0

I'm running the generate command on a bitcoin core fork (with difficulty = 1) and bitcoind running in another window and outputting the best/vs. hashes as it should when generate is running.

However, nothing has been mined yet; generate keeps returning empty brackets. A similar command worked on this machine so I know its powerful enough to mine at this low difficulty.

How do I check what's going wrong? Perhaps a verbose option for generate or something other than debug.log (this just outputs keypool return/keypool reserve throughout. I have also tried to mine in the debug console of QT client but with no luck either.

1

If you mean the generate function, which creates blocks on demand, it is only available for the Regtest mode. Use the -regtest option to run in Regtest mode.

If you mean the setgenerate mining function, it has been disable since the 0.13 version of Bitcoin Core, due to the fact that mining difficulty became too high for doing it with CPUs.

If you want to restore that functionality you will need to restore the mining functionality code from a previous version and try to integrate it again in the source code (you will need to recompile it).

debug.log is the reference log file. You can refine the log output through the command line options. See https://en.bitcoin.it/wiki/Running_Bitcoin

  • 1
    You can also use external mining software such as cpuminer. – Nate Eldredge Jan 18 '18 at 14:09
  • Nate that looks like a great idea. Thanks! – user3190635 Jan 18 '18 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.