0

i'm trying to install armory on ubuntu 12.04 but it is not working:

$ sudo dpkg -i armory_0.88.1-beta_i386.deb
Selecting previously unselected package armory:i386.
(Reading database ... 222699 files and directories currently installed.)
Unpacking armory:i386 (from armory_0.88.1-beta_i386.deb) ...
dpkg: dependency problems prevent configuration of armory:i386:
 armory:i386 depends on python-qt4.
 armory:i386 depends on python-twisted.
 armory:i386 depends on python-psutil.
dpkg: error processing armory:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 armory:i386

it looked like i needed to install packages python-qt4, python-twisted and python-psutil so i did this:

$ sudo apt-get install python-qt4 python-twisted python-psutil
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 armory:i386 : Depends: python-qt4:i386 but it is not going to be installed
               Depends: python-twisted:i386 but it is not installable
               Depends: python-psutil:i386 but it is not going to be installed
 python-qt4 : Depends: libqtassistantclient4 (>= 4.6.3) but it is not going to be installed
              Depends: sip-api-8.1
 python-twisted : Depends: python-twisted-conch (>= 1:11.0) but it is not going to be installed
                  Depends: python-twisted-mail (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-lore (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-news (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-runner (>= 11.0) but it is not going to be installed
                  Depends: python-twisted-words (>= 11.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

for some reason they did not want to install so i did this: (was this a bad move?)

$ sudo apt-get -f install

and after a massive amount of output in which it looked like many packages were removed??? nothing happened. armory still won't run and now i think i have screwed up some other valid packages since i have a lot of empty links with question marks on my unity bar. even the vim configuration file seems to have been altered!

help!

(i should also mention that i recently upgraded from ubuntu 10.04 to 12.04 and that may not have gone too smoothly for bitcoind)

  • 1
    LOL! I can imagine how that must feel to know you typed a -f and seeing apt just plow through all of those "WARNING: You are about to do something potentially harmful. ARE YOU SURE!?!?!" notices with reckless disregard! You may want to head over to Ask Ubuntu at this point because I think the problems are beyond bitcoin/armory issues. Try an apt-get check in the meantime which should report any remaining issues. – Neil Neyman Sep 23 '13 at 15:57
  • I'm not sure what is supposed to happen with install with no packages listed -- that doesn't seem to be in the docs at all. But another hint is in the future always run apt-get update before installing anything which syncs up your local package list with the latest available info. – Neil Neyman Sep 23 '13 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.