I installed MultiBit a few weeks ago and today it's not loading anymore. It displays the following Error in the logs:

The Blockchain "C:\Users\USER\AppData\Roaming\MultiBit\multibit.spvchain" could not be loaded. The Error was "org.jboss.netty.channel.ChannelException Failed to create a selector.".

I already tried deleting that file and then let multibit recreate it, but it doesn't help.

What am I doing wrong?

  • Can you see if you are using an older version of Java ? If you do 'java -version' on the command line you should see a version number something like : 1.7.0_40-b43. If it is significantly older than that e.g. 1.6.x then it would be worth updating it and trying again.
    – jim618
    Nov 15, 2013 at 15:59
  • It says java version "1.7.0_45" Java(TM) SE Runtime Environment (build 1.7.0_45-b18) Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
    – Flole
    Nov 15, 2013 at 17:14
  • i have this problem and i cant get my money in my wallet and i see the transaction on blockchain.info whats going on? i tried to delete multibit.spvchain and start multi bit sgain but the same problem excists. what should i do i loose alot of money if i dont fix this. van i export my wallet adress to another program and try to get them there??? please anyone help me with this problem
    – user12031
    Jan 10, 2014 at 15:18

1 Answer 1


It sounds like there is a problem in the locally stored block store file. You should be able to solve this by doing the following:

Find where MultiBit is storing your user data - this is shown on the very first line in the 'Message' tab when you start up MultiBit. (It is also explained in the help in 'Troubleshooting'.)

Shut down MultiBit

Go to your MultiBit user data directory - worked out above - and delete the file multibit.spvchain

Start up MultiBit again

MultiBit then syncs from a month or two ago and you should be running ok at that point.

  • I already tried it
    – Flole
    Nov 15, 2013 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.