1

Actually I'm making a logos windows exe (logosd and logos-qt) following the release process, which is mention on below path on any coin you can find that path, I'm working logos LGS Coin that's why I'm mentioning.

logos/contrib/gitian-descriptor/README

# Build Win32 dependencies: These three command successfully completed and generated a zip file

./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/boost-win32.yml
./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/deps-win32.yml
./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/qt-win32.yml

But when I run below mention command it will give me error

# Build Win32 release:

./bin/gbuild --commit logos=HEAD ../logos/contrib/gitian-descriptors/gitian-win32.yml

Error

/home/ubuntu/build/logos/src/leveldb/libleveldb.a: could not read symbols: Archive has no index; run ranlib to add one
collect2: ld returned 1 exit status
make[1]: *** [release/logos-qt.exe] Error 1
make[1]: Leaving directory `/home/ubuntu/build/logos'
make: *** [release] Error 2

I've search on internet found that execute these command ranlib libleveldb.a and it will compile, but still I'm getting same error again and again. So please let me know how to resolve that issue.

My System is ubuntu 14.04 64bit architecture.

  • Did you try these debugging steps? stackoverflow.com/questions/2765240/… – Nick ODell Apr 10 '15 at 15:22
  • Yes, I have tried these debugging steps, But still it will show me the same error. – Prabhat Chauhan Apr 13 '15 at 7:11
  • Hey guys, still any solution? im using ubuntu 16.04 and cant break this point. src/leveldb/libleveldb.a: could not read symbols: Archive has no index; run ranlib to add one – Petr Latal Jan 26 '18 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.