2

I have downloaded cgminer for linux and uncompressed it and tried to run it but clicking on the executable file does nothing it is marked as executable and still does not run. Is there something else I should do?

I tried to open this file:

File I tryed to open

Edit: Here is a screenshot from the directory cgminer is in from the "ls" command

enter image description here

  • Thank you for the screenshot. I'm installing Ubuntu on a Virtual Machine to look into the issue. – rrrrrrrrrrrrrrrr Dec 22 '13 at 9:24
  • I could download, compile and run cgminer with the steps described in my answer without any problem. Did you download the binaries or did you compile it from the source code? – rrrrrrrrrrrrrrrr Dec 22 '13 at 9:44
  • I downloaded the binarys – Qwertie Dec 22 '13 at 10:23
  • Can you link me the package? – rrrrrrrrrrrrrrrr Dec 22 '13 at 15:15
  • ck.kolivas.org/apps/cgminer I have " cgminer-3.8.5-x86_64-built.tar.bz2" – Qwertie Dec 22 '13 at 22:32
2

cgminer is a command-line software.

Open a Terminal and change the working directory to where you have your cgminer executable with the cd command. For example, if you have it on the Desktop you have to use the following command: cd ~/Desktop (where ~ indicates your home directory).

Then, if necessary, mark it as an executable file with the chmod +x cgminer command and finally run it with the ./cgminer command. Note that you will probably need to run it as the root user, so you probably want to run this command instead: sudo cgminer.

You can also specify command line options. For example, if your pool URL is http://foobarpool.net:3333, your username is qwertie.1 and your password is 1234 you can run cgminer with the following command so it is preconfigured and will start working right away: sudo cgminer -o http://foobarpool.net:3333 -u qwertie.1 -p 1234.

You can also specify lots of options for the GPU, fallback mining pools and other things. For a complete list, use this command: cgminer --help.

  • 1
    This gives me sudo: cgminer: command not found – Qwertie Dec 22 '13 at 0:09
  • 1
    Are you in the right directory? Where is your cgminer executable placed? Did you use cd correctly? – rrrrrrrrrrrrrrrr Dec 22 '13 at 0:11
  • 1
    cgminer is under home/Apps/cgminer. Here is the line from the terminal "/Apps/cgminer$ " – Qwertie Dec 22 '13 at 0:14
  • 1
    Try to run the ls command in that directory. Does cgminer show up in the list? – rrrrrrrrrrrrrrrr Dec 22 '13 at 1:00
  • 1
    yes. I even copied/pasted cgminer from ls to make sure I spelt it right, still go the same result – Qwertie Dec 22 '13 at 1:13
1

Go to the directory of cgminer.

Type

sudo -s

Type your password

Type

chmod +x cgminer

Type

./cgminer --help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.