New answers tagged

1

In the past, the standard method of building for Windows has been to use MinGW. Either have MinGW on Windows and compile from within it (may be more difficult) or cross compile it from a Linux environment. However, fairly recently, support for using MSVC has been added. Although the official binaries do not use MSVC, you can self compile using it. We even ...


0

With windows 10 you can now run linux directly on windows with the Windows Subsystem for Linux or is it one of those cross-compilers like MingGW that compiles code originally written for Linux so it can be executed in Windows? There is some option to build bitcoin core without MingGW by using cygwin, msys2 or Visual Studio Here is a complete guide: ...


0

Configuring npm to install global packages to your user directory goes a long way to make these pesky permission issues go away. See: https://docs.npmjs.com/resolving-eacces-permissions-errors-when-installing-packages-globally#manually-change-npms-default-directory


0

Found the problem. Had these lines in my .bashrc and commenting them out fixed it: alias gcc="gcc-8" alias g++="g++-8" export CC="gcc" export CXX="/usr/bin/gcc-8" export PATH=/usr/local/clang_8.0.0/bin:$PATH export LD_LIBRARY_PATH=/usr/local/clang_8.0.0/lib:$LD_LIBRARY_PATH Why this caused ./configure to error out, I have no idea. But problem solved.


0

I figured out the issue: there were some directories that were owned by root that needed to be owned by my user. I made myself owner of some npm-related folders, for instance: sudo chown -R `whoami` /usr/local/lib/node_modules ...and that seems to have fixed the issue.


0

Perhaps, if you want to generate a vanity address, I suggest you use Vanitygen Plus https://github.com/exploitagency/vanitygen-plus (More up to date and features) and to compile, run make -f Makefile after u clone the repo and cd into it.


0

Maybe the directory doesnt have the proper rights, try this command sudo chmod 777 If it still doesnt work try these flag before your install sudo npm install -g --unsafe-perm or sudo node-gyp rebuild -g --unsafe-perm then try again


Top 50 recent answers are included